[amsat-bb] WISP on 64-bits WIndows

Edson W. R. Pereira ewpereira at gmail.com
Thu Oct 19 19:26:19 UTC 2017

Has anyone successfully requested directory fill from Falconsat-3 using
Windows 64-bits? It seems that WISP sends a corrupt request to the
satellite on Windows 64-bits. I have tried running WISP on two different
machines. Both with Windows 64-bits -- one running Windows 7 64-bits and
the other running  Windows 10 64-bits. On both, every time MSPE requests a
directory fill, I get a "NO -5 PY2SDR" response from the satellite. Roland
PY4ZBZ tried on his 32-bits Windows 10 system and the satellite replies
with a OK.

Comparing the directory fill request packet sent to the satellite by my
station and Roland's, it seems that, on my station, WISP is corrupting the
directory hole pair data and also introducing one more byte to the request.

This is PY4ZBZ (good) request:

10 F4 00 42 8F E5 59 FF FF FF 7F 0D 0A

This is PY2SDR (bad) request:

10 F4 00 BF 12 E0 59 FF FF FF FF FF FF 7F

73, Edson PY2SDR

More information about the AMSAT-BB mailing list