[amsat-bb] SATPC32 doppler correction stops working

Gabriel - EA6VQ ea6vq at dxmaps.com
Sun Jul 30 16:48:50 UTC 2017

After years on not being on the satellites I am trying to be active a little
again.  I have installed the trial version of SATPC32 12.8b in order to
automatically correct Doppler in the rig and it works fine for 5 to 10
minutes, but then it stops updating the frequency in the transceiver. No
error message or something, it just stops updating the frequency.


Some information:

-          Rig is an IC-9100

-          OS is Windows 10 64 bit

-          CAT is connected using the IC-9100 USB port (Silicon Labs CP210x
USB to UART Bridge)


Some tests I have already made and additional information:

-          The drivers I had for the CP201x were old. I have updated them
with the latest, but without luck.

-          I have tried running SATPC32 as administrator, without changes.

-          When the Doppler correction fails, the CAT communication is still
working. For instance I can change CW/SSB using the C+/C- button.

-          The only way to make it work again is to reconnect the IC-9100,
so that the COM port is created again in Windows, and obviously restarting

-          Years ago I remember I tried version 12.8b , in Windows XP, and
Doppler correction was working.

-          When I use the CAT communication in the same PC with the logbook
program, there are no issues.


Before you tell me that I should try version 12.8c, I have already done it
and it is worse: for instance, it not even changes the frequencies in the
rig when changing from one satellite to another, although CAT communication
has been stablished.


Anyone using SATPC32 on Windows 10 64 bit together with the IC-9100, with

Any idea of what to try next?

Is there some other program that I can use for Doppler correction?


73. Gabriel - EA6VQ


More information about the AMSAT-BB mailing list