[amsat-bb] SatPC32 on Ubuntu Mate/Wine

Rolf Krogstad rolf.krogstad at gmail.com
Sun Apr 30 20:19:07 UTC 2017

I am playing with Ubuntu Mate in hopes of replacing the aged PC I use for
satellite work.  I have installed Wine 1.8.7 and SatPC32 v12.8c.  I can't
get my COM ports working

The problem I am having is getting the Radio Setup of SatPC32 to work.
Note: I have radio control working with this same USB-COM device (with two
com ports) on the old Windows XP system which I am hoping to replace.  Same
Radios and Same USB-COM devices work on Windows XP.  The only variable here
is Ubuntu Mate Operating System.

I have verified that the FTDI USB-COM is shown as /dev/ttyUSB0 and ttyUSB1.
I run dmesg and it gives me the following:
[ 7162.258726] usb 3-1: New USB device found, idVendor=0403, idProduct=6010
[ 7162.258736] usb 3-1: New USB device strings: Mfr=1, Product=2,
[ 7162.258744] usb 3-1: Product: USB FAST SERIAL ADAPTER
[ 7162.258750] usb 3-1: Manufacturer: FTDI
[ 7162.258757] usb 3-1: SerialNumber: FT5V2HZV
[ 7162.269942] ftdi_sio 3-1:1.0: FTDI USB Serial Device converter detected
[ 7162.270131] usb 3-1: Detected FT2232C
[ 7162.273835] usb 3-1: FTDI USB Serial Device converter now attached to
[ 7162.277760] ftdi_sio 3-1:1.1: FTDI USB Serial Device converter detected
[ 7162.277816] usb 3-1: Detected FT2232C
[ 7162.281895] usb 3-1: FTDI USB Serial Device converter now attached to

I then went to /home/rolf/.wine/dosdevices and created symbolic links to
com3 and com4.  I also tried com1 and com2.

lrwxrwxrwx 1 rolf rolf   12 Apr 28 20:37 com3 -> /dev/ttyUSB0
lrwxrwxrwx 1 rolf rolf   12 Apr 28 20:39 com4 -> /dev/ttyUSB1

Then I go into radio control in SatPC32 and define the proper com ports for
radio 1 and radio two.  I exit SatPC32 and then reopen.

As SatPC32 opens I get two error messages, one for each com port defined in
radio control:
"Could not open COM3 for Radio 1.
Check whether COM3 is available on your system..."

I get the corresponding error message for COM4 on Radio 2.

Any linux experts who can help me with ideas on how to get the USB-COM
devices recognized in Wine?


Rolf   NR0T

More information about the AMSAT-BB mailing list