[amsat-bb] SatPC32 crashes

Erich Eichmann erich.eichmann at t-online.de
Tue Oct 18 06:13:57 UTC 2016

the problem is caused by the built-in USB-to-Serial adapter of the 
IC-9100 in front of the CI-V interface of the radio. CAT control of the 
IC-9100 works completely flawlessly (like it does with the IC-910H) if 
you connect the radio via it's traditional CI-V jacket instead via one 
of the USB ports.   The built-in USB-to-Serial adapter in front of the 
CI-V CAT interface  is fed by the radio and not by the PC like external 
adapters. So, if you switch off the radio while CAT control is still  
working you have the same situation as if you unplug an external 
USB-to-Serial adapter while data exchange is running.
I don't have an IC-9100 at present. I loaned one for 4 months when I 
programmed the routines for the radio. I observed also the error. When I 
switched off the radio first (while CAT control was running)  I got the 
repeated message :
“Internal error retrieving device control block for the port”. I have 
mentioned that in the FAQs file (fig. 5 o). I tried to trap the error. 
The error routine should switch off CAT control (C-) to prevent a crash, 
if I remember correctly,  but I  don't know now how reliably  it  works.
So, as Bob, KO6TZ, wrote: switch off the program first or disable CAT 
control (C-) before you switch off the radio.  .

I steered the radio also via the CI-V jacket using a CAT cable (= 
USB-to-Serial adapter + interface for level conversion) and also used an 
external USB-to-Serial adapter + my Icom CAT interface.  That works 
absolutely lawlessly because the adapter is fed by the PC and remains 
fed when you switch off the radio.

73s, Erich, DK1TB

Am 17.10.2016 um 22:58 schrieb Donald Olson via AMSAT-BB:
> Running XP with SatPC32 and the program does exactly what it is supposed to do with my IC-9100 and my Yaesu5 500 rotator.
> However when I am finished for the day and go to close it, it tells me "Access Denied."  And then I have to reboot the machine to shut it down.  What a nuisance.  I have tried running the program in Administrator mode, no help.  I have tried closing it through Task Manager...same message, "Access Denied."
> Anyone solved this problem?
> I am getting close to making my first contact.  But the pileups are dense and cannot get back more than my call sign.  No QSO yet.
> Don Olson WA5W
> _______________________________________________
> Sent via AMSAT-BB at amsat.org. AMSAT-NA makes this open forum available
> to all interested persons worldwide without requiring membership. Opinions expressed
> are solely those of the author, and do not reflect the official views of AMSAT-NA.
> Not an AMSAT-NA member? Join now to support the amateur satellite program!
> Subscription settings: http://www.amsat.org/mailman/listinfo/amsat-bb

More information about the AMSAT-BB mailing list