[amsat-bb] Re: SatPC32 Problems Connecting to TS2000

Erich Eichmann erich.eichmann at t-online.de
Sat Jan 19 02:19:05 PST 2013

the current SatPC32 version still uses the old MSComm32.OCX component to
manage the serial ports. The component supports only the port numbers 1 to
16. (It is possible to expand the numbers up to 255 by changing a single
byte in the binaray code of the component. However, I don't know whether
that would be legal.)

Meanwhile I have a new component from another manufacturer without that
limitation for a future version and I will probalby soon upload a patch 

I have mentioned the issue with the current component and how to fix it in
the FAQs file, see below.

73s Erich, DK1TB

Here the section from the FAQs file:
 L. Error message: Can't Open COMxx, Invalid Port number or similar
This error message appears if
1 ....
2. ...
3. the chosen Port has a port number > 16. The tool used by SatPC32 to
manage the serial ports supports only port numbers up to 16. The system,
however,  increases the port numbers with each installation of a new port
(i.e. a new USB-to-Serial adapter or if you connect the adapter to another
USB port). So,  port numbers can be 17 or higher. To fix the problem,  you
can decrease the number of the port you want to use to be 16 or less. To do
this,  do the following:
aa. In the Device Manager check which ports are available on the PC.
bb. Right click on the port number (> 16)  you want to change.
cc. Choose Properties - Port settings - Advanced.
dd. Open the list of possible COM  ports (click on the control to the right
of the port number).
ee. The  port numbers 1 - 16 (or at least most of them) will be marked as
"in use". Only the ports listed in the Device Manager are actually in use,
however. Choose one of the port numbers not actually in use. Ignore the
marking "in use" and the Windows warning. The change might require you to
reboot the PC to take effect.
Choose the new port number also in SatPC32 and restart the program.

----- Original Message ----- 
From: "Richard Lawn" <rjlawn at gmail.com>
To: <amsat-bb at amsat.org>
Sent: Saturday, January 19, 2013 1:13 AM
Subject: [amsat-bb] SatPC32 Problems Connecting to TS2000

> I've had intermittent problems with connecting SatPC32 to my TS2000 via
> CAT. I finally determined I thought that the Keyspan 4-port USB-Serial hub
> was the problem. I've had problems with it in the past so this wasn't a
> surprise. I dug out another single Keyspan USB-serial converter, plugged
> it
> in, had to reset the Com port to something higher (17) and tested it first
> with Ham Radio Deluxe. Whalla it worked connecting at 57600 baud rate. But
> I try to connect to the radio using the same parameters in SatPC32 and no
> dice. It tells me that com 17 isn't available. What am I missing. I am
> using VSP and could it be that I need to set up a pair. The ultimate goal
> is to control both the TS2000 for uplink and my Flex5KA with
> downconverters
> with SatPC32. It worked just fine including the Keyspan hub with my FT847
> but not with the Kenwood. What am I missing?
> Rick
> _______________________________________________
> Sent via AMSAT-BB at amsat.org. Opinions expressed are those of the author.
> Not an AMSAT-NA member? Join now to support the amateur satellite program!
> Subscription settings: http://amsat.org/mailman/listinfo/amsat-bb

More information about the AMSAT-BB mailing list