[amsat-dc] Need SatPC32 troubleshooting help

Stephan Greene ks1g04 at gmail.com
Mon Jun 4 19:30:20 PDT 2012


Getting back onto the satellites in prep for Field Day (and I've had
my 1st QSOs on AO-7, SO-50, and this evening, VO-52 - yay!).  Running
into weirdness now with SatPC32 controlling the transmit frequency on
my Icom 821. This is one of those, "well' I think it WAS working
correctly" situations (and no I don't know what I did, if anything, to
bugger it up). Or it may have always been there and I didn't notice it
until I started trying more passes and closer to max elevation/max
rate of doppler shift.

While transmitting, when the program sends the radio a frequency
correction (due to any combination of doppler and uplink tuning via
the screen controls), the transmit frequency shifts 5 MHz down on 70cm
(at least on AO-7, down from 435.x to 430.x) and up 1MHz (145.x to
146.x) when the uplink is on 2M.  Goes back to normal after I stop
transmitting and wait for the next correction, or toggle CAT control
off and back on.  So far, I've seen this on at least AO-7 and VO-52,
and confirmed it on the FO-29 settings.  Frustrating - I now have to
switch off the radio control and find my d/l the old fashioned-way.
Radio is otherwise responding to CAT commands normally.   The RX
frequency is unchanged throughout.  Radio is configured in satellite-R
mode, main band as d/l and sub-band as u/l.

I've tried different settings of baud rate and CAT command delay
without effect.  I also tried a 100% uninstalling and reinstalling
SatPC32 (pretty sure everything cleared because I had to reconfig the
program from scratch) without stopping this behavior.  Version is
latest (SatPC32 12.8b), registered (AMSAT-NA of course), running on
Windows7 64 (run it as administrator from my user account).  CAT
control of the radio is otherwise fine, addresses for main & sub bands
appear correct, CAT baud rate is 19k2, and CAT delay is 70, "use
sattelite mode" box is checked.  Slower baud rates and longer delays
did not clear the problem.  RF feedback into the control cable (USB
with built in serial converter) is plausible (I get some pickup on the
PC speakers on 2M, full power), not sure I have a good way to test for
that.

Assuming I don't find and fix the problem 5 seconds after I hit
"send", any suggestions to fix?  The problem is very repeatable and
very frustrating.

Thanks & 73
Steve KS1G

-- 
-----------------------------------------------------------------------------------------------------------------
Steve Greene  ks1g04 at gmail.com  <kay ess one gee zero four>@gmail.com
-----------------------------------------------------------------------------------------------------------------



More information about the AMSAT-DC mailing list