[amsat-bb] Spid ras rotator issue

Zachary Leffke zleffke at vt.edu
Mon Jan 15 18:29:57 UTC 2018

Hi Shakeel,
I have a bit of experience with the Alfa Spid systems, so hopefully this might help.  First question is what type of controller are you using?  We use the MD-01s at Virginia Tech (MD-02s would be behave the same), but I believe there is another controller option for these types of rotators (not sure if they have the same config settings in the other model, also not sure what the model designation is).

I can say for sure that the protocol for communicating with a RAS (alfa spid) rotator and a yaesu rotator are completely different.  I personally don't use SatPC32, so I'm not sure if there is an option in there for changing it to one of the spid protocols.  We have our MD-01s configured to communicate using the spid 'Rot2Prog' interface.  So if you see anything like that in the SatPC32 options, try using that instead of yaesu.

Alternatively, I *think* the MD-01s have a protocol config for emulating Yaesu systems.  If you hunt through the manuals/settings on the rotator controller there may be an option for selecting yaesu.  I'm not 100% sure, but it is possible that even if the option is in the controller for Yaesu, depending on your model and firmware version it might still not work (even though the option is in there, it might be for 'future use').  This is not something I've personally tested since we got the Rot2Prog interface working, but might be worth trying if SatPC32 doesn't have the configs for spid systems.

There is also an 'MD-01' option in the MD-01 rotator controller that exposes more advanced options to the control program......in my experience this is spotty and 'beta' firmware, and personally i don't trust it (though we interface with custom software, so the problems there could easily be entirely my fault in our SW).

Finally, at least for MD-01s, there is a configuration option that needs to be set to 'activate' the comm port setting.  We actually use the Ethernet module in our systems, but you might want to make sure that the equivalent setting for the serial port is 'enabled' on your controller.  In that same vein make sure you have the right port settings in there as well (baud rate, stop bits, etc.)

And last bit of advice (and I don't mean this to be snarky, as referenced in the other thread about linux mailing lists) is carefully read the manuals and make sure you have the correct manuals for all the settings I mentioned above.  I bring this up from personal experience because I *didn't* carefully read the manual and wasted a bunch of time because I didn't have the right settings on the controller.  Also, I bring this up because the manuals from Spid are a bit difficult to read through and sometimes not totally clear.  Further compounding the problem is that there are a few organizations involved with these systems and they each have their own manuals (I'm still not sure who does what between Alfa Spid in Canada and Spid Elektronik in Poland and I think theres one more group somewhere else).  The manuals can be found here:  http://www.alfaradio.ca/downloads/ (pretty accurate and I believe current) and also here if you have an MD-01/02 (careful, this link is a direct download of the pdf): https://www.haystack.mit.edu/edu/undergrad/srt/pdf%20files/MD-01%20en.pdf.

Summary:  I recommend using the Rot2Prog protocol on the controller (tried and true, been in use for a long time, so most 'beta' issues have been sorted).  Then, if possible, I'd try to see if SatPC32 has a controller option for 'spid' or 'rot2prog' or something along those lines instead of yaesu.  Finally, I believe there is a windows based client application that can be used to interface with the controller (at least there is for the MD-01s).  I'd recommend using that first with the controller to sort out all the settings and make sure it is working over the com port first, then try to switch over to using SatPC32 (I think the windows client can also act as a DDE client, so maybe it can be used in conjunction with SatPC32 over a DDE link).

For me there were lots of config testing and changes, sort of one at a time, until all the stars aligned and it started working.

Good luck! Hopefully this is helpful.  Let us know if you have more questions.

-Zach, KJ4QLP

----- Original Message -----
From: "shakeel saad via AMSAT-BB" <amsat-bb at amsat.org>
To: amsat-bb at amsat.org
Sent: Monday, January 15, 2018 12:49:04 PM
Subject: [amsat-bb] Spid ras rotator issue


I have spid ras azimuth elevation rotator. I have set up Satpc32 for yaesu 232 mode to connect with rotator. My Satpc32 is sending azimuth and elevation to comport. But rotator is not moving. Please tell how do I know my rotator is installed correctly. I have setup mode of rotator to ps. But how to confirm or check rotator is installed correctly. The rotator is moving with moving its supplied mouse. 

Any help 


Get Outlook for Android

Sent via AMSAT-BB at amsat.org. AMSAT-NA makes this open forum available
to all interested persons worldwide without requiring membership. Opinions expressed
are solely those of the author, and do not reflect the official views of AMSAT-NA.
Not an AMSAT-NA member? Join now to support the amateur satellite program!
Subscription settings: http://www.amsat.org/mailman/listinfo/amsat-bb

More information about the AMSAT-BB mailing list