[amsat-bb] Problem using USB-to-Serial adapters with Windows 10 Laptop.

Erich Eichmann erich.eichmann at t-online.de
Thu Jan 4 14:38:10 UTC 2018

Hello all,
I want to use 2 FTDI USB-to-Serial converters (US232R and FT4232H) with 
my  Laptop Acer Aspire with 64-bit Windows 10, Home edition. But the 
installation  of the (latest) FTDI drivers fails. I tried automaic 
installaion via the Windows Device Manager and manual installation by 
running the .inf file. With both methodes  I get the same  Windows error 
message, saying that Windows found drivers for the device, but an error 
occured during installation, see screenshot.   When I check the hardware 
for problems Windows says that there are no drivers installed for the 
US232R/ FT-4232H.

With a Toshiba Laptop and a Cativa desktop PC, both also with 64-bit 
Windows 10 Home, the installation worked flawlessly and the adapter 
generates the virtual COM ports

I googled for a solution but without success. There are more users who 
report the same error message with other USB-devices. There was a 
suggestion for Windows 7 to delete a file named InfCache.1. I can't test 
that, however, because  Windows 10 doesn't provide that file, the 
content has been moved to the registry.  The FTDI support suggested to 
first uninstall the drivers, but the problem remains.

Has anyone else encountered the same problem and is there a solution?

Many thanks for any support

73s, Erich, DK1TB

More information about the AMSAT-BB mailing list