[amsat-bb] usb to serial adapter woes

Larry Gerhardstein gerhardstein at montana.com
Sat Apr 10 16:36:32 PDT 2010

I hope someone can shed light.  I'm using SatPC32, but that does not 
affect this problem.

Awhile back I was forced to recycle both of my older computers that had 
one built in 9-pin serial port.  Then, I connected the built-in port to 
the GS-232B rotor interface.  I also purchased some HL USB-RS232 
USB-to-Serial adapters, a cable with USB on one end and a 9 pin RS232 on 
the other end.  I used this gadget to control my transceiver (which is a 

Now I have a new computer which has no (zero) built in serial ports.  
I'm trying to use two of the USB-to-Serial gadgets and have run into 
trouble.  If I disconnect all grounding back through the power, I can 
get one of the two to work, either the rotor or the rig-control, but not 
both at the same time.  Without disconnecting grounding, neither work.  
It does not matter whether I'm plugging the USB ends directly into the 
computer, using a passive USB hub, or a powered hub--same result.

All I have to do to get this to fail...is...  Even if the USB ends are  
not plugged into the computer and the rig control box is powered off and 
unplugged from power, if I just touch the metal shield on the USB cable 
going to the rig control onto the shield connection in the computer or 
hub,  that causes the rotor control to fail.  When it fails, The azimuth 
reading on the G-5500 drops all the way to zero.  The elevation meter is 

It acts like a ground loop somewhere, but where and how?  I've tried 
disconnecting the coaxes from the transceiver but no change.

I'm thinking about scrapping these USB-to-Serial things and going to a 
4-Port Keyspan box.


73, Larry W7IN - DN27 in Plains, Montana

More information about the AMSAT-BB mailing list