[amsat-bb] Re: Problem with Basic Stamp based tracker box serial display

Mark L. Hammond marklhammond at gmail.com
Tue Nov 17 17:20:00 PST 2009

Hi Michael,

Greg has given you sound advice about checking the voltage to the LCD.

The only problem I've ever had with the LCD was related to a BAD
CONNECTION to the pins on the LCD.  It exhibited similar symptoms as
what you describe.  I found that it lost good contact and would cause
the display to go dim or OFF.  Took me a little checking to figure
that one out.  Other than, I've had no issue with my SAEBRTrack
box..but then again, I helped design it ;)

Glad to see your return to the birds!!


Mark N8MH (formerly KC4EBR, and thus the EBR in SAEBRTrack)

Hi Michael,

When the display dies, does the rest of the box keep working?  If the whole
thing dies, then I'd suspect the 7805 (5v) power supply.  Does the 7805 get
hot?  If so, that's the problem; they have a built-in thermal shutdown for
over-temp and/or over-current.  What sort of heat sink do you have on it?

If the problem is limited to the display, then I'd take a look at what's
feeding it, power-wise, if it's different than the rest of the board.  Again,
I'd first look for things that are running too warm.

If there's no heat problem, I'd next look for RF problems, or other things that
can be cured with better shielding or grounding.  My controller (also
Stamp-based) was extremely sensitive to the electric glitches created when the
motors were turned off.  Kept losing its mind; I fixed it by adding more bypass
caps around the board.

Good luck,

Greg  KO6TH

> Date: Mon, 16 Nov 2009 19:23:08 -0500
> From: mat_62 at netcommander.com
> To: amsat-bb at amsat.org
> Subject: [amsat-bb] Problem with Basic Stamp based tracker box serial display
> I have a a homebrew tracking box designed around a Basic Stamp. It's
> known as the SaebrTrack, I built it from an article on the web. The
> circuit uses an LED display with a serial  "backpack" attached from
> Scott Edwards electronics to display the Azimuth and Elevation readings.
> The information is fed to it from the Basic Stamp.
>  Lately the display light will start flickering at times and then the
> letters will fade out completely as well. It takes turning the box off
> and back on to bring them back up. This seems to be a sporadic
> occurrence and can happen when the box is turning the rotators or
> sitting idle. There is no rotator control box, the entire operation is
> handled by this unit.
>  I just basically read the schematic and built this thing and then
> loaded the Stamp with the software. I'm not well versed in this
> technology. Could this be something as simple as voltage regulation?
> There is a 12V transformer that runs the DC rotator motors and a
> separate 6V transformer that takes care of the display  and indicator
> lights as well as feeding voltage to the position pots on the rotators.
> I believe there is a 7805 regulator in the 6V circuit if memory serves.
>  Any thoughts or ideas? I've checked for loose connections. Could the
> serial backpack display itself be causing this?
> Any help would be appreciated. It gets kind of annoying when it happens.
> Tnx and 73,
> Michael, W4HIJ

Mark L. Hammond [N8MH]

More information about the AMSAT-BB mailing list