[amsat-bb] Problem with Basic Stamp based tracker box serial display

Michael Tondee mat_62 at netcommander.com
Mon Nov 16 16:23:08 PST 2009

I have a a homebrew tracking box designed around a Basic Stamp. It's 
known as the SaebrTrack, I built it from an article on the web. The 
circuit uses an LED display with a serial  "backpack" attached from 
Scott Edwards electronics to display the Azimuth and Elevation readings. 
The information is fed to it from the Basic Stamp.
 Lately the display light will start flickering at times and then the 
letters will fade out completely as well. It takes turning the box off 
and back on to bring them back up. This seems to be a sporadic 
occurrence and can happen when the box is turning the rotators or 
sitting idle. There is no rotator control box, the entire operation is 
handled by this unit.
 I just basically read the schematic and built this thing and then 
loaded the Stamp with the software. I'm not well versed in this 
technology. Could this be something as simple as voltage regulation? 
There is a 12V transformer that runs the DC rotator motors and a 
separate 6V transformer that takes care of the display  and indicator 
lights as well as feeding voltage to the position pots on the rotators. 
I believe there is a 7805 regulator in the 6V circuit if memory serves.
 Any thoughts or ideas? I've checked for loose connections. Could the 
serial backpack display itself be causing this?
Any help would be appreciated. It gets kind of annoying when it happens.
Tnx and 73,
Michael, W4HIJ

More information about the AMSAT-BB mailing list