[amsat-bb] Re: Labjack u2 to steer g-5500 in SatPC32

Erich Eichmann erich.eichmann at t-online.de
Tue Jul 17 00:31:55 PDT 2007


Hello Charles,
I have the Labjack U12 and the Labjack U3 running on my PC. I can use both
devices alternatively without problems. But I also had problems when I first
tried to run the U3 and had to contact Labjack.

If you have the Labjack software for the U12 installed on your PC it is
necessary, first to download an update of the U12 software from the Labjack
website. The update will install the U12 software into a different program
folder "C:\Program Files\LabjackU12Legacy" instead of the program folder
"Labjack" as the older version did. The U3 software can then install into
"C:\Program Files\Labjack" without conflicts with the U12 software. Perhaps
it will be good to make sure that this folder is completely empty before you
install the U3 software.

If you constantly get an error message from SatPC32 that can't be fixed
uninstall the program with the Windows System panel. Since that will remain
some files in the SatPC32 program folder and the sub folders delete all
remaining files so that the SatPC32 program folder is completely empty
before you  re-install the program.

73s, Erich, DK1TB


----- Original Message ----- 
From: "Charles Reiche" <reichec at verizon.net>
To: <amsat-bb at amsat.org>
Sent: Tuesday, July 17, 2007 4:40 AM
Subject: [amsat-bb] Labjack u2 to steer g-5500 in SatPC32


> Has anyone gotten this working??
> Im using the  Circuit suggested by DK1TB that looks to be hand drawn and
is similar to the labjack u12 schematic.
> I set my rotor full scale voltages at 3.30v.
> At first I was not finding a file called ljackuw.dll when setting up my u3
in the rotoe setup boxes for satpc32.  I figured out that this file actually
belongs to the u12 driver files so I installed the u12 drivers too.
>
> after loading those drivers, I wasnt getting any error messages on startup
but was unable to control the rotor manually (in the labjack u3 server
program sprouted by satpc32.  At the time also, the feedback numbers in the
u3 server program was showing 1.7 something but not following the rotor box.
I tried manually entering some numbers in there but it cuased a cascadeing
crashing error message boxes that ran down my screen.  I closed out
everything and rebooted.
> I tried to restart satpc32 and now all i can manage to get is a divide by
zero error in german on startup.
>
> Using the LJ control panel program that came with my u3, I can see when i
set FIO4 and 5 to AIN  (analog in) i can see the rotors output when i turn
it by hand using the control box.  I can also used digital outputs 0,1,2,
and 3 to manually command the box to steer.  My circuit is working but
something on the software level is broken.... possibly with the drivers?  It
got worse after I rebooted.
>
> Any ideas???   Thanks.
>
> Charles Reiche
> N3CRT
> _______________________________________________
> Sent via AMSAT-BB at amsat.org. Opinions expressed are those of the author.
> Not an AMSAT-NA member? Join now to support the amateur satellite program!
> Subscription settings: http://amsat.org/mailman/listinfo/amsat-bb
>




More information about the AMSAT-BB mailing list