[amsat-bb] Labjack u2 to steer g-5500 in SatPC32

Charles Reiche reichec at verizon.net
Mon Jul 16 19:40:30 PDT 2007

Has anyone gotten this working??
Im using the  Circuit suggested by DK1TB that looks to be hand drawn and is similar to the labjack u12 schematic.
I set my rotor full scale voltages at 3.30v.
At first I was not finding a file called ljackuw.dll when setting up my u3 in the rotoe setup boxes for satpc32.  I figured out that this file actually belongs to the u12 driver files so I installed the u12 drivers too.

after loading those drivers, I wasnt getting any error messages on startup but was unable to control the rotor manually (in the labjack u3 server program sprouted by satpc32.  At the time also, the feedback numbers in the u3 server program was showing 1.7 something but not following the rotor box.  I tried manually entering some numbers in there but it cuased a cascadeing crashing error message boxes that ran down my screen.  I closed out everything and rebooted.
I tried to restart satpc32 and now all i can manage to get is a divide by zero error in german on startup.

Using the LJ control panel program that came with my u3, I can see when i set FIO4 and 5 to AIN  (analog in) i can see the rotors output when i turn it by hand using the control box.  I can also used digital outputs 0,1,2, and 3 to manually command the box to steer.  My circuit is working but something on the software level is broken.... possibly with the drivers?  It got worse after I rebooted.

Any ideas???   Thanks.

Charles Reiche

More information about the AMSAT-BB mailing list